Prerequisites - Enterprise Java Content management system - Hippo CMS

Prerequisites

Prepare your environment to create a Hippo CMS project.

You start a new Hippo CMS project by generating a Maven project from the Hippo CMS archetype. For this, you need a working installation of Java 8, and Maven version 3.2.3+.

This tutorial also assumes that you have some basic knowledge on how to use Maven. Make sure your Maven installation works properly and that, if you are on Windows, you don't have spaces in either your Maven installation path or the path to your local Maven repository.

Working with an IDE

Since Hippo CMS is a Maven based project, you can open it and run it using almost any IDE you wish. Importing a Maven project into an IDE can really speed up your development, maintenance and testing procedures. Here are instructions on opening, running and debugging Hippo CMS from within Eclipse or IntelliJ:

Continue to create the project

Prerequisites

Prepare your environment to create a Hippo CMS project.

You start a new Hippo CMS project by generating a Maven project from the Hippo CMS archetype. For this, you need a working installation of Java 8, and Maven version 3.2.3+.

This tutorial also assumes that you have some basic knowledge on how to use Maven. Make sure your Maven installation works properly and that, if you are on Windows, you don't have spaces in either your Maven installation path or the path to your local Maven repository.

Working with an IDE

Since Hippo CMS is a Maven based project, you can open it and run it using almost any IDE you wish. Importing a Maven project into an IDE can really speed up your development, maintenance and testing procedures. Here are instructions on opening, running and debugging Hippo CMS from within Eclipse or IntelliJ:

Continue to create the project