7.8.11 release - Enterprise Java Content management system - Hippo CMS

7.8.11 release

December 14, 2015

Here is a new update for the projects running on 7.8.xx series, a new maintenance release 7.8.11 is available.  The Hippo stack is updated with latest version of apache commons collection 3.2.2 following Security Advisory Concerning Java Deserialization Vulnerability. To have these new dependencies in your project bump the release version to 7.8.11. We also recommend you to upgrade to our latest 10.1.x version where you can have awesome features. You can bootstrap or create a new project following the trials page.

The new versions of these dependencies have been available for a while, now they are bundled in this release. If the project has been using these dependencies via project pom file, than remove while using this maintenance release. We encourage all projects to remain on the regular maintenance release. Using a tagged artifact that is not yet part of a maintenance release should only be done if there is a specific reason and only after testing in your specific project setup.

ARTIFACTS & VERSIONS in 7.8.10

CORE

Addon HST Config Editor 1.11.07
Addon Channel Manager 2.24.12
Addon Search Service 1.01.02*
Commons 1.02.06
CMS 2.24.20*
HST 2.26.17*
Packages 2.24.01
Repository 2.24.18*
Services 1.02.03
Utilities 1.01.04
Project 22.2

FORGE

Content Blocks 1.09.04
Dashboard Document Wizard 1.03.11
Easy Forms 2.12.14
ECM Tagging 4.05.04
Gallerypicker 1.11.06
Poll 1.06.01
Properties 2.08.02
Relateddocs 2.08.12
Robotstxt 1.06.00
Selection 2.06.07
Sitemap 1.04.03
Taxonomy 1.09.06*
TCMP 1.07.07

Enterprise

Addon Newsletter Manager 1.03.02
Addon Reporting 1.06.02
Addon Targeting 2.24.05
Addon Edition Indicator 1.01.02
Addon Advanced Search 1.02.07
Eforms 1.02.11*

Dependencies

Jackrabbit 2.2.12-h1

(*) - New artifact versions

BUG

CMS

  • [CMS-9664] - Bug in Xinha editor (hippo 7.8.x) Enter cleans textfield (Chrome Only)
  • [CMS-9712] - Update Apache Commons Collections library version to 3.2.2 on 7.8.x artifacts

HST

  • [HSTTWO-3421] - FormDataCleanupModule leaves half the expired items

7.8.11 release

December 14, 2015

Here is a new update for the projects running on 7.8.xx series, a new maintenance release 7.8.11 is available.  The Hippo stack is updated with latest version of apache commons collection 3.2.2 following Security Advisory Concerning Java Deserialization Vulnerability. To have these new dependencies in your project bump the release version to 7.8.11. We also recommend you to upgrade to our latest 10.1.x version where you can have awesome features. You can bootstrap or create a new project following the trials page.

The new versions of these dependencies have been available for a while, now they are bundled in this release. If the project has been using these dependencies via project pom file, than remove while using this maintenance release. We encourage all projects to remain on the regular maintenance release. Using a tagged artifact that is not yet part of a maintenance release should only be done if there is a specific reason and only after testing in your specific project setup.

ARTIFACTS & VERSIONS in 7.8.10

CORE

Addon HST Config Editor 1.11.07
Addon Channel Manager 2.24.12
Addon Search Service 1.01.02*
Commons 1.02.06
CMS 2.24.20*
HST 2.26.17*
Packages 2.24.01
Repository 2.24.18*
Services 1.02.03
Utilities 1.01.04
Project 22.2

FORGE

Content Blocks 1.09.04
Dashboard Document Wizard 1.03.11
Easy Forms 2.12.14
ECM Tagging 4.05.04
Gallerypicker 1.11.06
Poll 1.06.01
Properties 2.08.02
Relateddocs 2.08.12
Robotstxt 1.06.00
Selection 2.06.07
Sitemap 1.04.03
Taxonomy 1.09.06*
TCMP 1.07.07

Enterprise

Addon Newsletter Manager 1.03.02
Addon Reporting 1.06.02
Addon Targeting 2.24.05
Addon Edition Indicator 1.01.02
Addon Advanced Search 1.02.07
Eforms 1.02.11*

Dependencies

Jackrabbit 2.2.12-h1

(*) - New artifact versions

BUG

CMS

  • [CMS-9664] - Bug in Xinha editor (hippo 7.8.x) Enter cleans textfield (Chrome Only)
  • [CMS-9712] - Update Apache Commons Collections library version to 3.2.2 on 7.8.x artifacts

HST

  • [HSTTWO-3421] - FormDataCleanupModule leaves half the expired items